Results 1 to 7 of 7

Thread: Another successful road trip for the SX4

  1. #1
    Join Date
    Nov 2016
    Location
    Toronto, Canada
    Posts
    862

    Another successful road trip for the SX4

    With the US land border open for Canadians the GF and I decided to make the trip over yesterday. Usually we just head over to Buffalo/Niagara Falls for some shopping and picking up some stuff that I send to a US place for pickup to bring back to Canada.

    It's been almost 21 months since the last time we were over there (last time was end of Feb 2020 couple weeks before the crap dropped and shut down the land border). We decided to head over to Rochester so from our place to there and back was pushing 500kms (2.5hrs each way). Left yesterday almost 7am got home just after 6pm.

    I had the car ready to go for a Florida trip that didn't happen for late November due to timing of the border opening (we needed to know around the summer time) whether we could drive there and arrange for hotel stay and/or decision to fly instead.

    So as posted up somewhere in "off topics" back in mid Sept. I did an trip up north to Algonquin instead no issue driving the car there and back and yesterday was the same. Cruised there nicely with the cruise control on, needed to step on it a few times to pass some tractor trailer trucks or slow pokes in the right lane and it did it all perfectly. I was generally going along at about 107km/h (so close to the 65mph speed limit), a few cars had passed me going much faster and one got busted soon after passing me probably at about 75-80mph then a NY state trooper pulled out from behind the armco on the left side of the highway and flashed the light show.

    Did all our Rochester stuff (stopped at 4 places), headed back to NF stopped to pick up a parcel the GF sent to my US pick up place then on to Whirlpool bridge to get back to Canada. There was a bit of a line up there (usually we go right to the booth with our Nexus). This line up was unusually long and it took almost 45 mins before we got up to the booth for customs. The SX4 idled its way up there without a whimper everything working as it should. There is no doubt in my mind I would make the Florida trip there and back in my car no problem, there could be an opportunity next year for that Florida trip and I'm planning almost the same trip that I didn't get to do this year and as of right now I still want to drive the car there (unless I come across a wickedly priced flight that I just couldn't pass up) so we'll see.

    BTW, we were bringing back almost US$300 worth of stuff, told the CBSA person what we bought and the total amount and he waved us through so a nice ending to this trip in the SEXY4!!!!!
    Last edited by Cman; December 5th, 2021 at 07:48 AM.
    10 SX4 6sp AWD, 17 CX-3 AWD
    19 Corvette ZR1
    09 Z06 (gone), 13 Shelby GT500 (gone)

  2. #2
    Join Date
    Nov 2016
    Location
    Toronto, Canada
    Posts
    862
    Sexy 4 came through again today, headed up to Vaughn this morning (north of Toronto) to my tire mounting place to get the 500 tires mounted to the new Konigs (car was loaded up with 4 wheel boxes and Motegi setup).

    Got home an hour and a bit later and with the GF headed to Niagara Falls again for shopping and picking up a Nav update USB drive I bought for the Corvette. Was driving the car on the winter all weather setup (Toyo Celsius tires (stock sizing) on Mazda steel wheels). Got there no problem and hit all the places and made our way back home no issue, SX4 running great the whole time. If only this car had a bit more oommppphhh in the HP dept. It would be a hoot to drive (that's my beef with this car along with the stupid lazy throttle) but I have to say with the work I've done it has been very reliable and that can't be beat.

  3. #3
    Join Date
    Nov 2016
    Location
    Toronto, Canada
    Posts
    862
    Last week day trip to Kingston Ontario to do a boat cruise. Got there and back no issues.

    I can now confirm that next year in the spring time the car will be doing the major trip that I wanted it to do the last 2 years. It will be an almost 4000kms road trip in the US going towards Kentucky, Tennessee, and Arkansas. I'm confident the car is ready and will make it there and back no problem................we'll see.

  4. #4
    how many miles do you have no on the car? What are your car specs again?

  5. #5
    Join Date
    Nov 2016
    Location
    Toronto, Canada
    Posts
    862
    Just under 105k miles. It's a 2010 car 6sp AWD.

  6. #6
    oh wow, it has low miles. I have heard and seen many manual SX4 getting super high miles.

  7. #7
    Join Date
    Nov 2016
    Location
    Toronto, Canada
    Posts
    862
    Yeah sorta low for the 12 years it's been on the road. When I got it in 2014 from the OE owner it had just under 60,000 miles.

    I've put about 46k miles on it these last 8+ years.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •