Results 1 to 9 of 9

Thread: ABS light permanently on. 2009 1.9 diesel

  1. #1

    ABS light permanently on. 2009 1.9 diesel

    Hi, I wonder if anyone can give me any clues on how to self diagnose this issue please. A short while ago the ABS light came on during a long run. It went out when the vehicle was switched off and restarted. Since then this intermittent fault has become permanent. It doesn't appear to have any effect on the performance of the car.
    Many thanks
    Bob

  2. #2
    Join Date
    May 2011
    Location
    Ottawa, Ontario
    Posts
    1,418
    check your sensor wire. have you done brake job recently. could have been damaged.
    Please fill up profile..awd or fwd.
    we do not have diesel in NA.
    2007AWD auto.212k km..K/N air filter,AUXinput,Grp34size Battery
    Fixes..alternator,swybarlnk,cntrlarm,innertierod,P wiperarm,Rexhaustjnt,Raxleseals,Ujoints,idler,tens ioner pulleys.

  3. #3
    Thank you very much for getting back to me. I have only recently purchased the vehicle so I'm not sure of its history. The wheels/brakes have not been attended to in the last couple of months so I suspect it is not as a result of wheel removal.
    Sorry to seem so ignorant, but where does the ABS wire start and finish?
    The car is a UK spec 4 wheels drive diesel, I'm currently using it in the Spanish Pyrenees.

  4. #4
    Join Date
    Dec 2011
    Location
    Chicoutimi, Quebec, Canada
    Posts
    668
    IN addition to request for your profile, what is the mileage of the car now ? ABS check light also comes with wheel bearing failure, that usually impairs wheel speed pick up. AN advance scanner can tell which wheel would be at fault.
    It could be like this:
    Generic OBD-II ABS Codes
    C0035 - Left Front Wheel Speed Circuit Malfunction
    C0225 - Left Front Wheel Speed Sensor Circuit Open
    C0226 - Left Front Wheel Speed Signal Missing
    C0227 - Left Front Wheel Speed Signal Erratic
    C0051 - LF Wheel Speed Sensor Circuit Range/Performance
    C0040 - Right Front Wheel Speed Circuit Malfunction
    C0041 - Right Front Wheel Speed Sensor Circuit Range/Performance
    C0221 - Right Front Wheel Speed Sensor Circuit Open
    C0222 - Right Front Wheel Speed Signal Missing
    C0223 - Right Front Wheel Speed Signal Erratic
    C0229 - Drop Out of Front Wheel Speed Signals

    C0045 - Left Rear Wheel Speed Circuit Malfunction
    C0046 - Left Rear Wheel Speed Sensor Circuit Range/Performance
    C0050 - Right Rear Wheel Speed Circuit Malfunction
    C0235 - Rear Wheel Speed Signal Circuit Open
    C0236 - Rear Wheel Speed Signal Circuit Missing
    C0237 - Rear Wheel Speed Signal Erratic
    C0238 - Wheel Speed Mismatch
    Last edited by LMP; December 12th, 2019 at 09:54 AM.
    2011 sx4 JX AWD CVT 37000km(Oct2019) Also drives 2015 KIA Sorento AWD 2.4

  5. #5
    Join Date
    May 2011
    Location
    Ottawa, Ontario
    Posts
    1,418
    there is one each in both front wheels. only one in rear.driver rear for NA SX4.
    Goto RockAuto web page to see how the sensors look.
    the wires came out of the wheel bearing hub. You need to remove wheels.

    You might want a mechanica to hoist it up
    2007AWD auto.212k km..K/N air filter,AUXinput,Grp34size Battery
    Fixes..alternator,swybarlnk,cntrlarm,innertierod,P wiperarm,Rexhaustjnt,Raxleseals,Ujoints,idler,tens ioner pulleys.

  6. #6
    I'm struggling to get Blue Driver OBD-II to give me any error messages at all. As soon as I resolve that I'll have another go at it.

  7. #7
    Join Date
    May 2011
    Location
    Ottawa, Ontario
    Posts
    1,418
    Do U use SZviewer app?
    2007AWD auto.212k km..K/N air filter,AUXinput,Grp34size Battery
    Fixes..alternator,swybarlnk,cntrlarm,innertierod,P wiperarm,Rexhaustjnt,Raxleseals,Ujoints,idler,tens ioner pulleys.

  8. #8
    No, I have a BlueDriver app

  9. #9
    It could be a broken a wire to an abs sensor.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •