Results 1 to 7 of 7

Thread: New Head Unit

  1. #1
    Join Date
    Feb 2018
    Location
    Roma Qld
    Posts
    7

    New Head Unit

    So . . . I know what I am doing this weekend.

    head unit.jpg

    Hopefully not too much drama. Supposed to be plug and play for the SX4. Trickiest part (I hope) will be routing the wiring for, and mounting, the reversing camera. Mounting the receiver for the GPS may be a bit tricky too but shouldn't prove too much hassle I hope.
    Last edited by Charleswb; March 11th, 2018 at 08:20 PM.
    2012 SX4 FWD CVT Hatch
    Roma, Qld, Australia

  2. #2
    Join Date
    Dec 2017
    Location
    Seattle, WA
    Posts
    37
    Awesome! Let us know how the install goes and how well the reversing camera is! I always wonder where's a good place to mount it without it being too obvious.
    2009 AWD | MT

  3. #3
    Join Date
    Feb 2018
    Location
    Roma Qld
    Posts
    7
    Quote Originally Posted by griffinu View Post
    Awesome! Let us know how the install goes and how well the reversing camera is! I always wonder where's a good place to mount it without it being too obvious.
    Yeah that was going to be my next question here. I have had a cursory look and am undecided as how best to route wiring from the reversing light to an appropriate position given it's a hatch.
    2012 SX4 FWD CVT Hatch
    Roma, Qld, Australia

  4. #4
    Join Date
    Oct 2017
    Posts
    136
    It was a bit of a pain to run the camera cable through the rubber grommets and into the vehicle. The rest wasn't too bad. I got a license plate mounted camera. It looks a little out of place but not too bad. I was able to covertly run the cable into the hatch without any undo-able modifications to anything.

    I want to see if the Chinese android head unit that I have will work off of the CAN bus. The connector is missing the wires, but the pins are in the radio. I'll have to hook that up and see if I get any extra functionality.

  5. #5
    Join Date
    Feb 2017
    Posts
    42
    Any update on this? I'm planning to upgrade my HU also.

  6. #6
    Join Date
    Feb 2018
    Location
    Roma Qld
    Posts
    7
    Installing the head unit (and even the wiring to the HU for the reversing camera) was easy -- basically plug and play. And then do some re-mapping in setup so the steering wheel controls act as you'd expect.

    Mounting the camera that came with my unit was a challenge of sorts, whilst not the size of a box-brownie or anything, it's not a particularly discrete unit. Wiring from the head unit was easy. I just routed along under the trim on the sills of the driver & passenger doors. Removing the rear tail/brake/indicator/reversing light assy so as to attach wiring was a bit nerve-wracking, it's held firmly and I was worried I would break it. (No easily available spares out here in the bush).

    Given the (relative) bulkiness of the camera and the fact that this was my late father's car and he had a rear nudge bar mounted as he was paranoid about being rear-ended, I decided to just bring the wiring for the camera out through the rear bumper but in a position protected by the bar.

    The unit works well, as does the reversing camera. Only 2 "issues":

    1. The Android version is oldish (4.4 I think) so some of the apps look a bit "daggy" as we'd say down here.
    e.g. the app to play audio cd's doesn't list *any* info about the disc or track playing (just "Track 01" etc)

    2. Something I had not considered (although I should have) is that since this is basically a computer/tablet, the unit takes a good 15-20 seconds to boot up after starting the engine. Living in a small town this means it feels like I am half way to my destination before the radio or whatever starts playing. (It's not quite, but feels like it)

    All in all I am happy with the unit and what it does.
    Last edited by Charleswb; April 28th, 2018 at 11:04 PM.
    2012 SX4 FWD CVT Hatch
    Roma, Qld, Australia

  7. #7
    Join Date
    Aug 2018
    Location
    Yorkshire
    Posts
    9
    What model headunit did you install ?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •