Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Bluetooth for 2008 SX4

  1. #1
    Join Date
    Feb 2018
    Posts
    47

    Bluetooth for 2008 SX4

    Hi,

    I'm looking to add bluetooth connectivity to my newly purchased SX4. Would be nice to keep the CD player for kids music, but not essential. I use my phone for NAV, and intend to do so in the future. Adding a backup camera and/or new speakers seems like a lot of work, so no plans for those.

    Another member is selling a reasonably priced Chinese head unit with nav.
    I've also looked at locally sold reasonably priced double DINs at bestbuy, canadian tire etc - but not sure if any of these will be plug and play, nor how to figure this out.

    Have also considered buying the AUX cord and then plugging in a cheapo bluetooth, but this feels decidedly inelegant.

    Any recommendations for what I want/need? Low cost is a priority!

    MT
    Suzuki SX4 | 2008 | hatch | auto | AWD | 135,000km
    Subaru Forester | 2014 | auto | AWD | 70,000km

  2. #2
    Join Date
    Dec 2010
    Location
    Bucharest, Romania
    Posts
    123
    Depending on the type of HU you have (Clarion or Panasonic), you could use a Yatour module:
    - http://s.aliexpress.com/QZv6nEzM?fromSns=Copy to Clipboard]Panasonic[/URL];
    - http://s.aliexpress.com/qURBvMBb?fromSns=Copy to Clipboard]Clarion[/URL].

    Sent from my MI MAX 2 using Tapatalk
    2010 SX4 1.6 VVT 4x4 GS trim level Bright RED

  3. #3
    Join Date
    Aug 2011
    Location
    Southern Alberta, Canada
    Posts
    203
    Quote Originally Posted by mikefly View Post
    Hi,

    I'm looking to add bluetooth connectivity to my newly purchased SX4. Would be nice to keep the CD player for kids music, but not essential. I use my phone for NAV, and intend to do so in the future. Adding a backup camera and/or new speakers seems like a lot of work, so no plans for those.

    Another member is selling a reasonably priced Chinese head unit with nav.
    I've also looked at locally sold reasonably priced double DINs at bestbuy, canadian tire etc - but not sure if any of these will be plug and play, nor how to figure this out.

    Have also considered buying the AUX cord and then plugging in a cheapo bluetooth, but this feels decidedly inelegant.

    Any recommendations for what I want/need? Low cost is a priority!

    MT
    Low cost would be going for the AUX cable and a bluetooth receiver. That's what I did, and it works like a charm.

    Bought the AUX cable from AliExpress for ~$5 shipped. From Amazon, I ordered an Anker bluetooth receiver for ~$25, and a 12v powered USB hub for another ~$15 to power everything along with my dash cam.

    Used a couple wads of Sugru (~$5)to mount a disc magnet to the dash, adhered a metal disc to the receiver, and routed the cable into the dash by the steering wheel.



    Zero issues.


    Sent from my iPhone using Tapatalk
    Current: 2008 SX4 JLX Hatchback ~ White Pearl ~ MT/iAWD ~
    R.I.P.: 2008 SX4 JX Hatchback ~ Silver ~ MT/iAWD ~

  4. #4
    Join Date
    Feb 2018
    Posts
    47
    Interesting.
    This cable?

    This anker?

    At first blush, it looks like the Kinivo version turns off and on automatically.

    Quote Originally Posted by iamclaus View Post
    Low cost would be going for the AUX cable and a bluetooth receiver. That's what I did, and it works like a charm.

    Bought the AUX cable from AliExpress for ~$5 shipped. From Amazon, I ordered an Anker bluetooth receiver for ~$25, and a 12v powered USB hub for another ~$15 to power everything along with my dash cam.

    Used a couple wads of Sugru (~$5)to mount a disc magnet to the dash, adhered a metal disc to the receiver, and routed the cable into the dash by the steering wheel.



    Zero issues.


    Sent from my iPhone using Tapatalk
    Suzuki SX4 | 2008 | hatch | auto | AWD | 135,000km
    Subaru Forester | 2014 | auto | AWD | 70,000km

  5. #5
    Join Date
    Aug 2011
    Location
    Southern Alberta, Canada
    Posts
    203
    Quote Originally Posted by mikefly View Post
    Interesting.
    This cable?

    This anker?

    At first blush, it looks like the Kinivo version turns off and on automatically.
    This Anker:
    https://www.amazon.com/gp/aw/d/B0176...BoL&ref=plSrch

    That's the correct cable, and the Anker does need to be turned on every time.


    Sent from my iPhone using Tapatalk
    Current: 2008 SX4 JLX Hatchback ~ White Pearl ~ MT/iAWD ~
    R.I.P.: 2008 SX4 JX Hatchback ~ Silver ~ MT/iAWD ~

  6. #6
    Join Date
    Feb 2018
    Posts
    47
    Cool, thanks! The Anker I linked to was not an anker at all! Appreciate Confirmation on the cord. Will it really take 1-2 months to arrive!?

    Thanks also to shpeedy for the ya tour suggestion - claus’s will be much less costly so will try it!

    Side note: although fm works great, for some reason AM tuner does not work. Separate antenna?
    Last edited by mikefly; March 11th, 2018 at 06:14 PM.
    Suzuki SX4 | 2008 | hatch | auto | AWD | 135,000km
    Subaru Forester | 2014 | auto | AWD | 70,000km

  7. #7
    Join Date
    Feb 2018
    Posts
    47
    All ordered! First time on Aliexpress. Paid double to get the cord in less than 1000 years.
    Suzuki SX4 | 2008 | hatch | auto | AWD | 135,000km
    Subaru Forester | 2014 | auto | AWD | 70,000km

  8. #8
    Join Date
    Feb 2018
    Posts
    47
    Chinese wire has now been with customs for 10 days. I should have probably shipped it to America.
    Suzuki SX4 | 2008 | hatch | auto | AWD | 135,000km
    Subaru Forester | 2014 | auto | AWD | 70,000km

  9. #9
    Join Date
    Feb 2018
    Posts
    47
    Got wire today! Took almost a month with customs - but it's here and installed. I probably should have put the 3.5mm female somewhere better, or routed the wires internally, but I was too excited to plan properly. Ah well - I think it won't matter much when the wires are out of the way.

    Music works well enough - although the quality of the speakers is all the more apparent.
    Calls are at a lower volume - I don't understand why. Weird.

    Unit powers off when the engine turns off. Annoying!

    My AM radio doesn't work - the internets suggest a wire has come loose. Will look at this when there's some daylight, before snapping back the panels in place.

    Thanks for all the advice.
    Suzuki SX4 | 2008 | hatch | auto | AWD | 135,000km
    Subaru Forester | 2014 | auto | AWD | 70,000km

  10. #10
    Join Date
    May 2014
    Location
    Champaign, IL
    Posts
    394
    Quote Originally Posted by mikefly View Post
    ..My AM radio doesn't work - the internets suggest a wire has come loose.
    You will have to splice in a wire to provide power to the AM antenna line in the head unit connector cable. Someone on the forum very recently did this and posted about it.
    2008 sx4 awd auto hatch touring

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •