Page 4 of 4 FirstFirst ... 234
Results 31 to 39 of 39

Thread: Stehignite's Disco Potato Turbo Build

  1. #31
    Join Date
    Aug 2017
    Location
    West Bend, WI
    Posts
    87
    Got off work early so I was able to get a fair amount of things done. My subframe brace is rusted out and i finally pulled the replacement out of the attic and put it in. took me only 10 min to do which I was surprised. You can see through the damn thing. So I started out with a somewhat complete kit from midnightsx4, and he originally got it from AdR. So I was reading through AdR's build thread and found out that I installed the fan in the wrong spot . I thought it was there because the stock fan under the filler cap was extra deep and caused interference. I learned from reading it was the ac fan that was replaced because the plastic melted. it is fairly close to the exhaust. So I pretty much had to redo everything i did the other day. When I finished that I built the pump bracket, which ended up turning out fantastic. I love my rubber isolators. If you cant already tell, I'm not building this just to whip together a turbo hatch. Part of the fun is the build, and showcasing skill and talent. Most will go unnoticed but I enjoy designing things and building them to a higher standard than the norm. I digress. Wired the pump up to the relay, and tidied up the wires.

    Tomorrow I plan to wire in the ecu and install the injectors. Turbo gets mounted in the weekend. In the last pic you can kinda see the intended intake path. the rear pipe will be much shorter but you get the idea. Gonna put a bung near the bov for a wastegate reference, gonna also add some other bungs for temp probes or meth injection and whatever else I wanna throw at it.







    2007 SX4 Hatchback J20A Manual, turbo install in progress; http://clubsx4.com/forum/showthread.php?t=8665
    also own a 1996 X90 4wd 4 inch lift on 30's G16B Manual

  2. #32
    Join Date
    Aug 2017
    Location
    West Bend, WI
    Posts
    87
    I have a lot of updates. Holey Moley. So Friday morning I started working on the piggyback bracket. It mounts to the fuse box bolt on the strut tower and another vacant body nut next to the engine loom tie wrap. Took a bit to get right but it turned out pretty good. I edited and printed out the images from the FIC thread shultzey made. One thing to note is that the ignition power lead is is not red in the factory loom, it is a black red. should be easy enough for someone to figure out if they looked up the port on the connector. I got everything hooking up And put the toggle lead, aux in, and the switched 12v lead in its own loom as after I work the bugs out I plan to do a couple things. one is to link up the wideband for datalogging in the aux input. I will hopefully run a dual calibration, if I ever wanna run race fuel. For the switched output I think I might use that for water injection, or a boost safety cutout. Getting the cable terminated was a very fun and relaxing process. A bit daunting at first nonetheless.




    2007 SX4 Hatchback J20A Manual, turbo install in progress; http://clubsx4.com/forum/showthread.php?t=8665
    also own a 1996 X90 4wd 4 inch lift on 30's G16B Manual

  3. #33
    Join Date
    Aug 2017
    Location
    West Bend, WI
    Posts
    87
    Got the stock header off, and pulled out the oil plug above the filter. I then put the turbo feed line in and put it to the side and mounted the manifold. took a couple tries as it was a sequence to getting them threaded correctly. I had to unbolt the upper radiator mounts to get it to slip passed the aftermarket fan. stock fan wouldnt have been any better. In the 2nd pic it shows I have a half inch of space between the manifold and the radiator. Thankfully the engine mounts are so wide that power flex should not cause it to hit. it should just move up and down relative to the fan. Ran the lines and mounted the downpipe. Clocked the turbo housing to be where I anticipated it.



    2007 SX4 Hatchback J20A Manual, turbo install in progress; http://clubsx4.com/forum/showthread.php?t=8665
    also own a 1996 X90 4wd 4 inch lift on 30's G16B Manual

  4. #34
    Join Date
    Jun 2016
    Location
    Greensburg, PA
    Posts
    357
    I saw your post on FB earlier with the mani/turbo/intercooler mounted and it looks awesome. Eager to see the completion


    edit: lol see you posted it minutes before I posted
    2007 Suzuki SX4 hatch awd
    2011 Nissan Xterra PRO-4X
    1992 Nissan Sentra SE-R

  5. #35
    Join Date
    Aug 2017
    Location
    West Bend, WI
    Posts
    87
    Started cutting pipe and drilling holes and fabbing brackets to get the intake system wrung out. Everything all lined up as intended so this saturday my buddy will come weld it all together. I really like how simple and square the intake system is. The core is out of the way of the dip stick and the filler. I am hoping the valve cover can be removed without removing the turbo or the intake but its unlikely. I'd like to paint it something cool at some point. As you can see I have a paint marker as a spacer for now until its all welded up. I will then build a bracket at the right height from there.


    2007 SX4 Hatchback J20A Manual, turbo install in progress; http://clubsx4.com/forum/showthread.php?t=8665
    also own a 1996 X90 4wd 4 inch lift on 30's G16B Manual

  6. #36
    Join Date
    Aug 2017
    Location
    West Bend, WI
    Posts
    87
    Quote Originally Posted by Ricer_X_01 View Post
    I saw your post on FB earlier with the mani/turbo/intercooler mounted and it looks awesome. Eager to see the completion


    edit: lol see you posted it minutes before I posted
    Yea I still have a couple more posts to post. Posting individual levels to avoid text and image walls. Should be at least idling this upcoming saturday. I like to format updates with the text and then pictures. since the text size is so small compared to the pics individual captions may be hard to read.
    2007 SX4 Hatchback J20A Manual, turbo install in progress; http://clubsx4.com/forum/showthread.php?t=8665
    also own a 1996 X90 4wd 4 inch lift on 30's G16B Manual

  7. #37
    Join Date
    Aug 2017
    Location
    West Bend, WI
    Posts
    87
    Scored a nice bug shield from facebook marketplace for $10 locally on saturday, installed it with my trusty non-rusty nutserts and stainless hardware. not sure what it was designed to hang on with, maybe plastic body rivets. Looks amazing on the car. Should protect my newly painted hood from rock chips. Installed the boost control solenoid, and I did a bit of a sin. I now have american thread on my japanese car . I was going to tap the aluminum bracket with M4 but my m4 tap has a different thread than my stainless m4 hardware. 6-32 should have to do i guess. . Then I mounted the wideband plug to the frame, nothing interesting but better than flopping around.


    2007 SX4 Hatchback J20A Manual, turbo install in progress; http://clubsx4.com/forum/showthread.php?t=8665
    also own a 1996 X90 4wd 4 inch lift on 30's G16B Manual

  8. #38
    Join Date
    Aug 2017
    Location
    West Bend, WI
    Posts
    87
    All the pictures for tonight. I forgot to mention I installed a 3psi spring in the turbosmart wastegate actuator. I think the stock one is 8psi. Tomorrow I get some more goodies from frozenboost. Some 3/4 waterline bungs, bigger vacuum lines, radiator overflow lines. Other than welding up the intake, I still need to get the injectors flow tested and installed, and the turbo coolant lines plumbed in and the intercooler coolant system ran. I also will need to tidy up and reign in the braided lines to make sure they dont wear holes in anything. After its idling and taking throttle I will fish the usb cable into the cabin and do some testing with driving.
    2007 SX4 Hatchback J20A Manual, turbo install in progress; http://clubsx4.com/forum/showthread.php?t=8665
    also own a 1996 X90 4wd 4 inch lift on 30's G16B Manual

  9. #39
    Join Date
    Aug 2017
    Location
    West Bend, WI
    Posts
    87
    Installation Completed!

    Well, has been for some time now, but haven't had much time to post. I got the charge pipe/WTAIC all welded up. only costed me $100 for my friend to weld up. The routing as seen is turbo>BOV and wastegate boost source tap>intercooler>MAF sensor>aux bung>Throttle body. The aux bung is just plugged for now, but I intend to use it for meth injection at some point. I initially had many issues getting the engine to run, and as i found out, it was because my maf signals were reversed due to a typo on the FIC install thread. Fixed that and got it to run at least a lil bit. After it was running, i found out after it was warmed up it wouldn't It would die at idle.

    I updated the FIC firmware, and calibrated the TPS and RPM. Got much better there. Now I just need to get my fuel map tamed out. The factory ECU is applying all sorts of fuel trimming to accommodate, and so it will be super rich at certain times and lean at others. I am waiting to get an O2 sensor simulator from sweden or switzerland I forget where the guy is from. This way I can tune the open loop map while in closed loop without fuel trims skewing my logs. Once tuned I will run the stock O2.





    2007 SX4 Hatchback J20A Manual, turbo install in progress; http://clubsx4.com/forum/showthread.php?t=8665
    also own a 1996 X90 4wd 4 inch lift on 30's G16B Manual

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •