Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 22

Thread: Stehignite's Disco Potato Turbo Build

  1. #11
    Join Date
    Nov 2010
    Location
    North of Montréal, Canada
    Posts
    687
    Quote Originally Posted by Stehignite View Post
    I will be extending the inlets and outlets 4 inches on the intercooler, and putting the MAF sensor in the stock location.
    Good Idea. I had mine way too far away from the throttle plate, I had to program insane amounts of "accel pump" fuel to compensate, and still had a lean spot when snapping the throttle.
    former Suzuki Gold Master Tech

  2. #12
    Join Date
    Aug 2017
    Location
    West Bend, WI
    Posts
    58
    Quote Originally Posted by mdmead View Post
    Yes, the X-90 is cool! Is that a Yamaha RD peeking out in the background?
    Yes that is an RD60, thats right 60cc's! got many other bikes as well. some say i have too many some say not enough! I have about 15 motorcycles, all of them vintage.

    Quote Originally Posted by automat View Post
    Good Idea. I had mine way too far away from the throttle plate, I had to program insane amounts of "accel pump" fuel to compensate, and still had a lean spot when snapping the throttle.
    Good to know. main reason is I wanted to vent to atmosphere. From what I understand recirculating interrupts flow of the pre-turbo intake tract. Air would be forced to exit the filter. It is only done for noise reasons. I may be wrong here but thats my understanding. and I want it to make pshh noises

    Update-

    There is no update on the build right now. Sorry! In Wisconsin its turning spring. And Being the only person in the household physically capable, means I need to take care of responsibilities around the yard first.
    2007 SX4 Hatchback J20A Manual, turbo install in progress; http://clubsx4.com/forum/showthread.php?t=8665
    also own a 1996 X90 4wd 4 inch lift on 30's G16B Manual

  3. #13
    Join Date
    Aug 2017
    Location
    West Bend, WI
    Posts
    58
    Did a little bit of work on making some gauge pods. Just out of some PVC pipe, will bond it with the satellite radio blank cover, as my car was not equipped with it. Will have UEGO O2 gauge, Truboost gauge and an oil pressure gauge. all aem and should match the stock trim fairly well. I am not a body guy so we will see if i can get this pvc to look decent.


    2007 SX4 Hatchback J20A Manual, turbo install in progress; http://clubsx4.com/forum/showthread.php?t=8665
    also own a 1996 X90 4wd 4 inch lift on 30's G16B Manual

  4. #14
    Join Date
    Aug 2017
    Location
    West Bend, WI
    Posts
    58
    Got the gauge pod done as far as I want to go with it for now. Next step is putting in control arms, repairing subframe brace that is rusting out, installing extended wheel studs on the rear and 12mm hubcentric spacers. Ksport Coilovers should come in this week. I was trying to find a spot in the engine bay for the FIC6, there really isn't a good spot in stock form. Will likely be doing a battery relocation by putting 2 6v optima agm batteries in the spare tire tray. already have the 0 gauge wire ran back there, so I will just need to fab a insulated mount for a positve binding post in the bay. With the battery out of the way that will enable me to have some extra space for the piggy, and a meth injection reservoir in the future. I will upgrade to a 150 or 200 amp alternator, as I am getting a whine from a failed diode, and with the added sound system, and turbo related electronics an upgrade will be due.

    I have some sort of vibrating noise when i let off the throttle/cruising at higher rpms. the sound does not match rpm from what I understand. its some sort of rattle. Hopefully I am able to find the source of the noise. It doesnt appear to be rod knock


    2007 SX4 Hatchback J20A Manual, turbo install in progress; http://clubsx4.com/forum/showthread.php?t=8665
    also own a 1996 X90 4wd 4 inch lift on 30's G16B Manual

  5. #15
    Join Date
    Aug 2017
    Location
    West Bend, WI
    Posts
    58
    Coilovers come in tomorrow. would have came today but I took this to the shop to get the control arm bolts unseized, missed the delivery. I live in bumf*** no where, no need for signature confirmation. I digress. I installed the extended studs in the rear, was a breeze. unbolted the hub and drove em in with the impact. slipped on a 12mm hubcentric spacer. should fill the wheel well slightly better. I asked the guy at the shop to test drive and tell me what the rattling noise is. He thought it was bottom end noise, which is what I feared. I put the car on stands intending to pull the pan and inspect, but I thought I would remove the serpentine belt and check the accessories for good measure. Sure enough, bearing slop on the alternator. Crossing my fingers and hoping this is the issue.


    2007 SX4 Hatchback J20A Manual, turbo install in progress; http://clubsx4.com/forum/showthread.php?t=8665
    also own a 1996 X90 4wd 4 inch lift on 30's G16B Manual

  6. #16
    Join Date
    Apr 2013
    Location
    Sherbrooke, Quebec, Canada
    Posts
    1,754
    Great stuff keep us posted!
    AWD 2013. CVT. Custom SRI w/Apollo, RRM Crank Pulley, RRM piggyback ecu, Custom 2.25 Flowmaster exhaust, RRM Front/Rear Swaybars, UR Rear Strut bar, Megan Racing Coilovers, Techna-fit brake lines, Projector HID retrofit.

  7. #17
    Join Date
    Jan 2013
    Location
    East Hills, Wa
    Posts
    1,695
    I just found a video clip of me testing something when I had t/c setup.
    I miss that sound !
    Last edited by midnightsx4; April 18th, 2018 at 04:09 AM.
    How hard can it be?

  8. #18
    Join Date
    Aug 2017
    Location
    Canada
    Posts
    177
    God damn
    SX4 2007 AWD Manual
    Kizashi 2011 AWD CVT

  9. #19
    Join Date
    Nov 2010
    Location
    North of Montréal, Canada
    Posts
    687
    Technically, with the stock ECU in place you could still vent it after the MAF, because, technically ("ideally" I should say) the BOV will only open in conditions where the ECU would cut fuel anyways. in the real world, a leaking BOV will get you all sorts of issues with your tune, and when you finally fix it you'll end up having to retune everything.

    Mine had the MAF close to filter, and the return of the BOV was right before the turbo inlet. you could hear it but not as loud as in midnight's video.
    former Suzuki Gold Master Tech

  10. #20
    Join Date
    Aug 2017
    Location
    West Bend, WI
    Posts
    58
    It's been a while since an update! Ksport Coilovers installed. Subwoofer box complete. I added a viewing window to the sub box as well as some red LED's. I set up the coilovers to give me a lowered stance but still plenty of suspension uptravel. I set the suspension to bottom out before rubbing, and set the ride height with the preload, and checked for coil slop at full drop out. The front needs to be dropped a bit still for my liking.






    I bought a 200 amp alternator from ebay, and it was not the right one and does not fit, even though they say it will. I ended up ordering from Quality Power and they shipped it out today, The rep told me they use the same casings as OEM so it is guaranteed fit. We will see. But it definitely sucks having the car out of commission for so long :/

    Side note, went from 800px to 1024px image sizes. If anyone has issues with the larger size let me know.
    2007 SX4 Hatchback J20A Manual, turbo install in progress; http://clubsx4.com/forum/showthread.php?t=8665
    also own a 1996 X90 4wd 4 inch lift on 30's G16B Manual

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •