Page 4 of 4 FirstFirst ... 234
Results 31 to 35 of 35

Thread: How long have you had your SX4

  1. #31
    Join Date
    Jun 2018
    Posts
    13
    I bought mine (2008) for my wife off the showroom floor in 2009. It is now mine with a little over 100,000 miles on the clock.

  2. #32
    Join Date
    May 2016
    Location
    New England, USA
    Posts
    20
    2008 Sedan Touring 5MT. Rescued from a used car lot in Dec. of 2015 with about 110k miles on it (Have about 150k now), it was claimed to be a one-owner. I went from a 1999 Escort which I gave a lot, but it needed a lot (still). It's been the most fun and reliable little car I've owned so far, I regret nothing and love the relative rarity of it! The proximity key has kept me from locking keys in the car a few times already- including the trunk! Watch out when you only get one key at purchase!

    Since I got it I've changed the downstream O2, tune up, AUX cable, all brakes (it spit out a front pad in my driveway). As of this moment it sits like my avatar, waiting new suspension pieces up front, a shifter cable adjustment, transaxle drain, and a coat of Fluid Film.

  3. #33
    Join Date
    May 2012
    Location
    VT
    Posts
    263
    Bought in 2012 and just turned 99K
    She has needed struts, a couple wheel bearing and recently the alternator and I love this car !!
    2012 SX4 Crossover 6sp Tech

  4. #34
    Join Date
    Aug 2018
    Location
    Boulder, CO
    Posts
    11
    Original buyer in 2010, 85k
    :: 2010 AWD 6MT uber-base hatch: Red Hots jerkface exhaust, +30mm tire offset
    installing ASAP: Tema 4x4 Lift, tie rods, subwoofer, button start

  5. #35
    Join Date
    Nov 2010
    Location
    Las Vegas, NV
    Posts
    2,078
    Purchased April 2008, still going strong. Had to replace the wiper motor 3 days ago.
    The path to heaven runs through miles of clouded hell.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •