Page 1 of 3 123 LastLast
Results 1 to 10 of 27

Thread: Keyless Ignition Problems....

  1. #1
    Join Date
    Feb 2011
    Location
    PGH, PA
    Posts
    33

    Keyless Ignition Problems....

    Just recently been having issues with my 2009 SX4 Hatch keyless start. When I turn on my car I always make sure the "keys" are on my lap so the car can recognize that keys are present. Then it starts fine. Now within time of moving it the light indicator on dash comes on blinking the red key. Acting as if the keys are not present. I will hold the keys up to the steering column so it can recognize them but it never does. I tried taking it to the dealer but they cant "figure it out." Anyone else experience this?

  2. #2
    Join Date
    Nov 2010
    Location
    North of Montréal, Canada
    Posts
    575
    weak transmitter battery

  3. #3
    Join Date
    Feb 2011
    Location
    PGH, PA
    Posts
    33
    thanks!!!

  4. #4
    Join Date
    Nov 2010
    Posts
    262
    Quote Originally Posted by automat View Post
    weak transmitter battery
    Yep.

  5. #5
    Join Date
    Nov 2010
    Location
    UNC Wilmington
    Posts
    386
    Same thing happened to me its the battery ..... only problem is that I couldn't find the battery anywhere but the dealer
    RRM Sway Bar, RRM CAI, All windows tinted, Piggy back (Future mods: Lowering springs, powder coating rims)

  6. #6
    Join Date
    Nov 2010
    Posts
    1,159
    Quote Originally Posted by grkacl View Post
    Same thing happened to me its the battery ..... only problem is that I couldn't find the battery anywhere but the dealer
    Try Radio Shack.

  7. #7
    Join Date
    Nov 2010
    Location
    New Zealand
    Posts
    372
    That battery should be sold in lots of places. CR2032 batteries have so many applications that you can get them in supermarkets here.

  8. #8
    Join Date
    Nov 2010
    Location
    South Jersey
    Posts
    2,692
    Rite-Aid and CVS carry them.
    The average dog is a nicer person than the average person.
    Andy Rooney

  9. #9
    Join Date
    Nov 2010
    Location
    Serbia
    Posts
    1,516
    It happens to me too, but only at certain places in the city. Interference from some radio signals emitters, I guess. There is one particular spot (and I can see huge antennas on the top of the near by building) where I have to use good old key to unlock and start the car.
    ʇı ɟo ǝʇnuıɯ ʎɹǝʌǝ ʎoظuǝ ı 'ʎʇıuɐsuı ɯoɹɟ ɹǝɟɟns ʇuop ı

  10. #10
    Join Date
    Nov 2010
    Location
    central VA
    Posts
    93
    Wal-Mart had mine in stock - did it at the jewelry counter in 1 minute and they recycled the old one.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •