Results 1 to 7 of 7

Thread: 2013 Suzuki sx4

  1. #1
    Join Date
    Mar 2019
    Location
    Alberta, Canada
    Posts
    15

    2013 Suzuki sx4 squealing

    Hey guys Iím getting a squeal when the car is running, Iím not sure if itís just the belt or is there a common issue with one of the pulleys? Iíd like to order everything at once to save on shipping , thanks any help would be appreciated

  2. #2
    Join Date
    Nov 2021
    Location
    USA
    Posts
    101
    That’s a real vague question. You will need to pinpoint the squeal. Get yourself a mechanics stethoscope or a real long screwdriver and very carefully probe around to all your belt driven accessories/pulleys while it’s running to listen. You should find it rather quickly.
    2007 SX4 AWD, 2.0L Gasoline J20A, 5 speed manual, 214,000+ miles on original engine.

  3. #3
    Join Date
    Mar 2019
    Location
    Alberta, Canada
    Posts
    15
    Yah I’m not comfortable sticking stuck around rotating pulleys and belts could get ugly.
    I will start with a belt I suppose was hoping to get more feedback

  4. #4
    Join Date
    Dec 2011
    Location
    Chicoutimi, Quebec, Canada
    Posts
    966
    Quote Originally Posted by NvMySi View Post
    2013 Suzuki sx4
    "2013 Suzuki sx4" is not a problem. TO help others search for and find your problem if they have the same, your title can be changed to contain the identification of the problem type. THis is the purpose of the forums.
    ANd by the way, what is your car odometer reading ? THere are several mentions of squeals with the belt idle or tensioner ..but that generally occurs after the engine has accumulated some miles or km.....
    SO..precise details can bring more precise replies.
    Last edited by LMP; August 29th, 2023 at 06:28 AM.
    2011 sx4 JX AWD CVT 45000km(May2023) Also drives 2015 KIA Sorento AWD 2.4

  5. #5
    Join Date
    Mar 2019
    Location
    Alberta, Canada
    Posts
    15
    Quote Originally Posted by LMP View Post
    "2013 Suzuki sx4" is not a problem. TO help others search for and find your problem if they have the same, your title can be changed to contain the identification of the problem type. THis is the purpose of the forums.
    ANd by the way, what is your car odometer reading ? THere are several mentions of squeals with the belt idle or tensioner ..but that generally occurs after the engine has accumulated some miles or km.....
    SO..precise details can bring more precise replies.


    Iíve got 53,000kms so (33,000 miles)

  6. #6
    Join Date
    Dec 2011
    Location
    Chicoutimi, Quebec, Canada
    Posts
    966
    Quote Originally Posted by NvMySi View Post
    ...
    I will start with a belt....
    So..what has happened with the new belt ?
    2011 sx4 JX AWD CVT 45000km(May2023) Also drives 2015 KIA Sorento AWD 2.4

  7. #7
    Join Date
    Nov 2016
    Location
    Toronto, Canada
    Posts
    906
    Search is your friend:

    http://clubsx4.com/forum/showthread....=idler+pullies

    Post #8 onwards......................
    10 SX4 6sp AWD, 17 CX-3 AWD
    19 Corvette ZR1
    09 Z06 (gone), 13 Shelby GT500 (gone)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •